When I type in: paypal.com
Chrome redirects me to the French Paypal
https://www.paypal.com/cm/home.

I know what happened, a typo. I previously typed "paypal.cm"

I'm guessing there is a setting or a cookie that got set in Chrome.

Is there a way to find that individual setting and remove it?

I realize I could go to settings and delete ALL cookies and history and that would probably solve it.

However, I'm a computer geek and want to know if I can delete just that ONE setting that redirects to French?

Thank you,
Jackson